Смердокрыл

WMO Editor crash

10 posts in this topic

Hey!

Cromon made an awesome tool called WMO editor and it was working perfectly for me, until one day it started crashing on startup for unknown reasons.

Here is the error message:

Spoiler

eNKgkyzbZSo.jpg

 

I tried compiling the source myself. Here's the error from VB:

Spoiler

VnfVrztAyYQ.jpg

 

Share this post


Link to post
Share on other sites

Another problem with wmo editor: I used to be perfectly able to load big wmos (such as Stormwind, Undercity, etc.) with WMO editor, but now it keeps giving me the "System.IO.FileNotFoundException", even though the file is clearly present in the MPQ archive.'

Could someone help me deal with this issue, or at least suggest another tool/way to remove unwanted doodads from a WMO?

Share this post


Link to post
Share on other sites
4 hours ago, Смердокрыл said:

Another problem with wmo editor: I used to be perfectly able to load big wmos (such as Stormwind, Undercity, etc.) with WMO editor, but now it keeps giving me the "System.IO.FileNotFoundException", even though the file is clearly present in the MPQ archive.'

Could someone help me deal with this issue, or at least suggest another tool/way to remove unwanted doodads from a WMO?

open the wmo in 010

replace the m2 you don't want

with spell\invisible.m2 I think that what it cold but you need to check

 

 

Share this post


Link to post
Share on other sites
36 minutes ago, Skarn said:

You can use Blender addon for WMOs. Look it up on github.

I found it on github, but I get an error when I try to enable the addon
minJHcf0-mM.jpg

Also, I remember having used it some time ago, and I don't think it included doodad editing. Are you sure it does now?

Share this post


Link to post
Share on other sites
39 minutes ago, Смердокрыл said:

I found it on github, but I get an error when I try to enable the addon
minJHcf0-mM.jpg

Also, I remember having used it some time ago, and I don't think it included doodad editing. Are you sure it does now?

1

Of course, I am sure, I developed it... This error is weird. Make sure you're using the recent distribution of Blender and the proper version of addon.

Share this post


Link to post
Share on other sites
Just now, Skarn said:

Of course, I am sure, I wrote developed it... 

1

Oh ok

1 minute ago, Skarn said:

This error is weird. Make sure you're using the recent distribution of Blender and the proper version of addon.

1

I'm using blender 2.78b and the latest version of the addon (just downloaded from github)

Share this post


Link to post
Share on other sites

Do you have Skype or  Discord? I am afraid, I won't be able to tell what's going on remotely.

Share this post


Link to post
Share on other sites
11 hours ago, Skarn said:

Do you have Skype or  Discord? I am afraid, I won't be able to tell what's going on remotely.

No need, I updated blender to 2.78c and it works fine now. However, I don't see the doodads when I load the wmo. Is there a tutorial on how to change those settings (e.g. wow path) properly?

Share this post


Link to post
Share on other sites

At the wmo tab choose the doodadset you want and the it will be loaded.
All the paths to wow folder and to modelviewer log could be changed at the user preferences>addons

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now