Sign in to follow this  
Followers 0
Degen

[WoD 6.2.4] Troubleshooting worldserver

6 posts in this topic

I've been trying to get a WoD server up and running to no avail. Using TrinityCore's latest WoD branch and a fresh 6.2.4 client, but the extractors that I compile won't populate the maps/mmaps/vmaps folders correctly and throw a bunch of errors.  I tried using Mr. DK's extractors from his tutorials on a different site, they seem to work and I get the files but when booting up the worldserver can't see the vmaps for some reason and crashes, version issues i'm guessing. Here's the server log.

 

TrinityCore rev. f17cb00ee36f 2017-08-13 15:24:53 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file D:/Build/bin/RelWithDebInfo/worldserver.conf.
Using SSL version: OpenSSL 1.0.2j  26 Sep 2016 (library: OpenSSL 1.0.2j  26 Sep 2016)
Using Boost version: 1.59.0
Updating Auth database...
>> Auth database is up-to-date! Containing 11 new and 97 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 5 new and 67 archived updates.
Updating World database...
>> World database is up-to-date! Containing 124 new and 1910 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 9 new and 104 archived updates.
Realm running as realm ID 1
Using World DB: TDB 720.00
Using enUS DBC Locale
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir D:/Build/bin/RelWithDebInfo/
WORLD: MMap data directory is: D:/Build/bin/RelWithDebInfo/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: D:/Build/bin/RelWithDebInfo/vmaps
VMap file 'D:/Build/bin/RelWithDebInfo/vmaps/0000.vmtree' does not exist  ((It does))
Please place VMAP-files (*.vmtree and *.vmtile) in the vmap-directory (D:/Build/bin/RelWithDebInfo/vmaps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

 

If anyone has any ideas the help would be appreciated.

Share this post


Link to post
Share on other sites

Is DataDir set correctly?

what is the output of the extractors?

Share this post


Link to post
Share on other sites

The Data directory looks correct. Points to the folder with the server binaries and dbc/maps/mmaps/vmaps.

Here's the output from the compiled mapextractor. (Is there any way to enable logging for it?)

For comparison here's the output from the downloaded mapextractor.

Share this post


Link to post
Share on other sites

Uh, you realize that master = 7.2.5.24742, not 6.2.4?

Share this post


Link to post
Share on other sites

Nope did not realize that. So i'm trying to use extractors for 7.2? That's weird, I cloned the WoD branch and compiled them out of that. Maybe not. I'll double check everything and give it another go.

Share this post


Link to post
Share on other sites

Update. 

So I've downloaded the 6.2.4 TrinityCore and TDB releases and finally have a core up and running. The only thing is, it's ripe with errors. Boots fine though.

Is this just the state of the core at the time it was abandoned? Or am I missing a semicolon somewhere..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0