Zehlendorf

Cloak model

24 posts in this topic

Hello, someone know where can get the .m2 files for new cloak models, like those one

http://www.wowhead.com/item=87636/cloak-of-the-forgotten-emperor

http://www.wowhead.com/item=152179/juggernaut-cloak&bonus=3610:1472

because not having the right model the .blp only applies to the normal model of the cloak that I have, as you can see in the photo :

WoWScrnShot_102517_011247.thumb.jpg.49f8

I hope someone can help me with this, thanks in advance. 

 

Share this post


Link to post
Share on other sites

There are no model files for them. Cloaks are geosets of the character models. You will have to change all of those and add a geoset for the new cloak. Since you already seem to be retroporting, just use retroported character models and you’re done.

Share this post


Link to post
Share on other sites

Hmm, Im using the characters models from legion, what should I do now?XD

Share this post


Link to post
Share on other sites

I wonder if it would be possible to make the cloak geoset transparent where there's no texture (I think the render flag is Mod2X, but I'm not sure)

Share this post


Link to post
Share on other sites

you need to change the render blendingmode to (alpha testing) flag to (two sided) its all in the m2 renderflags

then apply the flag to the cloak in the skin01 file

Share this post


Link to post
Share on other sites
5 minutes ago, MR.Farrarie said:

you need to change the render blendingmode to (alpha testing) flag to (two sided) its all in the m2 renderflags

then apply the flag to the cloak in the skin01 file

How can I tell which geoset is the cloak?

Also, why don't blizzard do that? It seems much more efficient than creating a new geoset for every new type of cloak.

Share this post


Link to post
Share on other sites
1 hour ago, MR.Farrarie said:

you need to change the render blendingmode to (alpha testing) flag to (two sided) its all in the m2 renderflags

then apply the flag to the cloak in the skin01 file

I not have the (two sided) in render blendingmoded. what should i do now?Untitled.thumb.jpg.bc8f65175cff1f033eda1

Share this post


Link to post
Share on other sites
13 minutes ago, Zehlendorf said:

what should i do now?

Replace "Opaque" (0) with "AlphaTesting (1)". That renderflag is now transparent. If your cape uses that renderflag, it will have transparency enabled.

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, Смердокрыл said:

How can I tell which geoset is the cloak?

u6cgQbl.jpg

3 people like this

Share this post


Link to post
Share on other sites
12 hours ago, Inico said:

u6cgQbl.jpg

Thanks very much, you are really helpful as always!

 

Still don't understand why blizzard don't do that though

1 person likes this

Share this post


Link to post
Share on other sites

Mutli-Converter hasn't been updated for a while and variables name got changed by blizzard maybe ? thanks for the tutorial btw @Inico

Share this post


Link to post
Share on other sites
On 25.10.2017 at 8:16 PM, Inico said:

u6cgQbl.jpg

Hey!

I just tried doing that by changing the render flag used by the geoset, I even tried changing all possible render flags to the same thing - it all acts seemingly right (textures become kinda transparent when it's mod2x and no flags, for example), but the transparent area of the texture is still black color, as if it is in the texture itself!

Share this post


Link to post
Share on other sites
10 hours ago, Смердокрыл said:

but the transparent area of the texture is still black color

Are you sure the texture has transparency?

Just tested it with a random cloak and transparency works fine in WotLK:
ij8cTRC.jpg

yTd6AKu.jpg

(ignore the tauren body textures, I use him as my test subject for multiple model edits)

10 hours ago, Смердокрыл said:

textures become kinda transparent when it's mod2x

If the renderflag is Mod2x the darker parts of your texture automatically become transparent, even when the texture doesn't have transparency itself, so it doesn't matter. Maybe the texture doesn't have an alpha channel.

Share this post


Link to post
Share on other sites
19 hours ago, Inico said:

If the renderflag is Mod2x the darker parts of your texture automatically become transparent, even when the texture doesn't have transparency itself, so it doesn't matter. Maybe the texture doesn't have an alpha channel.

1

Ok, so I'm testing this cloak and so far I could only get these results:

Opaque/Mod/Decal:
9tiv4tu3wAg.jpg
Add/Mod2x:
hhZk2_IojE4.jpg
Fade/Deeprun_Tram:
ajrh3re8ixE.jpg
Unk_wod (kinda like opaque with unlit flag):

54guZZXd37o.jpg

 

Whereas I want the red stuff to be completely opaque, while the black stuff (the texture IS transparent there, and blplab identifies it as such if you click show/hide alpha) to be completely transparent

Share this post


Link to post
Share on other sites
1 hour ago, Смердокрыл said:

the texture IS transparent there, and blplab identifies it as such if you click show/hide alpha

It shouldn't be happening. I don't know why you are testing it with other renderflags. Just with transparent (1) is enough.

Try using my texture. It's used by this item: Cloak of Darkness. And here is the tauren male m2 with transparent renderflag.

I only tested it in WotLK, though. So if you are using another game version it may not work the same way.

One thing you can do if the problem persists: convert the texture to png and then convert it back to BLP. It fixes some WoD texture problems (also, check if it loses its transparency when you convert it to png).

Share this post


Link to post
Share on other sites
57 minutes ago, Inico said:

Try using my texture. It's used by this item: Cloak of Darkness

Mod:
pJgsGQkKur4.jpg

Mod2x:
DNMHn_jcMyQ.jpg

 

57 minutes ago, Inico said:

So if you are using another game version it may not work the same way

I'm on Cata

57 minutes ago, Inico said:

One thing you can do if the problem persists: convert the texture to png and then convert it back to BLP. It fixes some WoD texture problems (also, check if it loses its transparency when you convert it to png).

Didn't help, unfortunately :(

Share this post


Link to post
Share on other sites
36 minutes ago, Смердокрыл said:

I'm on Cata

I just tested it. Cloak transparency doesn't work in Cataclysm or Mop. Only WotLK. Cloaks seem to be applied the same way body textures works, and that's why it doesn't read alpha channels. Tested on 4.0.6 and 5.4.8.

Share this post


Link to post
Share on other sites
30 minutes ago, Inico said:

I just tested it. Cloak transparency doesn't work in Cataclysm or Mop. Only WotLK. Cloaks seem to be applied the same way body textures works, and that's why it doesn't read alpha channels. Tested on 4.0.6 and 5.4.8.

Is there any way to change that? I mean, is that server-side or inside the client itself?

Share this post


Link to post
Share on other sites
11 hours ago, Смердокрыл said:

Is there any way to change that?

I don't know, never modded in Cata+. I guess you can try adding the transparency with blend mode overrides, but the flags are different.

11 hours ago, Смердокрыл said:

is that server-side or inside the client itself?

It's inside the client itself.

Share this post


Link to post
Share on other sites
2 hours ago, Inico said:

I don't know, never modded in Cata+. I guess you can try adding the transparency with blend mode overrides, but the flags are different.

I tried following your tutorial exactly, but PyModelEditor seems unable to Edit Textures of the humanmale model (wotlk version) and gives error key 15. Also, in the .skin files, there was no d4 field, so I assumed, judging by order, that it's the one called op_count in the template I'm using (which seems to be the same as yours, except for this) and changed that. In the end, nothing really changed (same results as I posted before).

An unrelated thought: the client does allow transparency for the character's eyeglow. Would it be possible to fool it by switching the two around and the activating the needed geoset by spell applied on item equip, for example?

Share this post


Link to post
Share on other sites
5 hours ago, Смердокрыл said:

but PyModelEditor seems unable to Edit Textures of the humanmale model

PymodelEditor doesn't work with cata+ models or those with .anim files, sadly.

5 hours ago, Смердокрыл said:

the client does allow transparency for the character's eyeglow. Would it be possible to fool it by switching the two around and the activating the needed geoset by spell applied on item equip, for example?

It also shows transparency for hair and "extra" (a.k.a. "tauren fur") textures. However they are bound to the model and can't be replaced by a spell or item, as far as I know. It would be possible if you added each cloak texture to "charsections.dbc" for every race and gender and made a spell for each cloak in the game, but that would be crazy.

Share this post


Link to post
Share on other sites
16 minutes ago, Inico said:

PymodelEditor doesn't work with cata+ models or those with .anim files, sadly

I mean when it's in the wotlk stage, after I do m2i-m2 (legion) and then downconver with Adspartan's to wotlk
 

17 minutes ago, Inico said:

It also shows transparency for hair and "extra" (a.k.a. "tauren fur") textures. However they are bound to the model and can't be replaced by a spell or item, as far as I know. It would be possible if you added each cloak texture to "charsections.dbc" for every race and gender and made a spell for each cloak in the game, but that would be crazy.

What I meant is deleting the cloak mesh, or making it empty, while replacing the eyeglow geoset, for example. with the actual cloak mesh, and activating it through a spell such as the one you linked in chat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now