leeviathan

[SOLVED] Porting character models to TBC causes stuttering

1 post in this topic

I recently released my WoD Character Models for 2.4.3 (see here: http://www.modcraft.io/index.php?topic=13815.0 ) and everything is working except this strange new issue with the game stuttering/freezing every time a patched-in character model is loaded.

It doesn't seem to have anything to do with the WoD character models in particular, but rather changing ANY character model; I've tested ports from vanilla, wotlk, etc. Even switching .M2s from the very same client all cause the same issue; for example: just renaming DraeneiFemale.m2 to BloodElfMale.m2 and placing it in the Character/BloodElf/Male/ directory causes the same hiccup to occur when the client loads BloodElfMale.m2

In fact, changing even 1-bit of superficial information in the hex code of any patched-in character .M2 file will cause the issue; for example: in 010 editor changing the model name from "DraeneiFemale" to "DraeneiFemalf" does it, so does just changing the the client version from a "7" to "4".

Does anyone have any insight on this issue? Could this be some kind of anti-cheat thing? It happens on every server I've tested on. Help wanted, thanks!

 

UPDATE: Of course I'd figure out a solution 10 minutes after posting after weeks and weeks of struggling to find a solution. The solution, or hacky work-around, was to change the location of the character models from "Character\..." to "Creature\..." and update the CreatureModelData.DBC file to reflect this.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now